Follow

I'm using Internet Explorer version 8 and I can't log in

We’re really sorry but as you’re using Internet Explorer 8 there are lots of things on the site that just won’t work for you as this version is now out of date and un-supported. To carry on using citysocializer you will need to upgrade your browser. Here’s what to do: 

For the fastest and easiest solution click here to download Chrome and use this to visit the site. 

OR click here to check which operating system you’re on and then download either Internet Explorer 11.

If you don’t want to upgrade your browser and would prefer to cancel your membership email us at support@citysocializer.com and we will help you do this.

Was this article helpful?
1 out of 1 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk